MVC required?

Aug 20, 2010 at 12:17 AM

Is MVC required to use this kit?

 

Coordinator
Aug 22, 2010 at 2:21 PM

To use the kit as-is, you would need to use MVC 2 and .NET 4.

You can certainly re-purpose much of the code to work for either a traditional ASP.NET or desktop application.

In the coming months a full fledged sample MVC application will be built out with the framework (all open source) to help others come up to speed with both MVC and Facebook. 

Hope this helps.

-Patrick.

Aug 27, 2010 at 7:37 PM

Patrick:

How about also making facesharp integratable with StarterSTS as an alternative to having to use the oAuth code? Then you would be able to use many STS's such as Twitter or Google to authenticate instead of wholely relying on FB... check it out at:  http://startersts.codeplex.com/.  Ultimately, this would allow sites to be much more flexible

-Mark